Search Our Site

Our Newsletter

Our Ramblings

Cisco – Two LAN, Two WAN ISP and NAT

We recently received a request from a rural customer who was tired of their unreliable 1Mbps ADSL line to add a second ADSL line to their network. The line was ordered and installed and we then added a second ADSL wic interface to their router and set to work making it work. Our brief was to make it work so that each LAN was associated with one WAN link and only used that WAN link. This is how we went about it.

Clearly the second interface needed to be associated with a second dialer created to log in and manage the second connection. Furthermore, we needed to add a second DHCP pool. This new config is shown as follows:

DHCP config:-

ip dhcp pool pollux
   network 192.168.200.0 255.255.255.0
   default-router 192.168.200.1 
   dns-server 62.6.40.178 62.6.40.162 

As you can see this connection is using BT DNS servers.

Dialer config:-

interface Dialer1
 description btbusiness
 ip address negotiated
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 2
 no cdp enable
 ppp authentication chap pap callin
 ppp chap hostname xxxxxxx
 ppp chap password xxxxxxx

We then needed to allocate a second default route to the router and this was achieved by means of the following command:-
ip route 0.0.0.0 0.0.0.0 Dialer1

We created an access list to handle the new traffic relating to the new DHCP network as follows:-
access-list 22 permit 192.168.200.0 0.0.0.255

and then we added a new access list to ensure that the traffic on each LAN network remained segregated from the other LAN. This was done as follows:-

access-list 112 deny   ip 192.168.1.0 0.0.0.255 10.0.0.0 0.255.255.255
access-list 112 deny   ip 192.168.1.0 0.0.0.255 172.16.0.0 0.15.255.255
access-list 112 deny   ip 192.168.1.0 0.0.0.255 192.168.0.0 0.0.255.255
access-list 112 permit ip 192.168.1.0 0.0.0.255 any
access-list 122 deny   ip 192.168.200.0 0.0.0.255 10.0.0.0 0.255.255.255
access-list 122 deny   ip 192.168.200.0 0.0.0.255 172.16.0.0 0.15.255.255
access-list 122 deny   ip 192.168.200.0 0.0.0.255 192.168.0.0 0.0.255.255
access-list 122 permit ip 192.168.200.0 0.0.0.255 any

Finally we needed to apply route maps to mechanise the access lists, putting them to work maintaining segregation and ensuring correct operation. The following two route maps were configured:-
route-map pollux permit 22
 match ip address 122
 set interface Dialer1
!
route-map castor permit 12
 match ip address 112
 set interface Dialer0

Putting it all together our new configuration was as follows:-

version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
service sequence-numbers
!
hostname xxx-core-router
!
boot-start-marker
boot-end-marker
!
security authentication failure rate 3 log
security passwords min-length 6
logging buffered 512000 debugging
enable secret xxxxxxx
!
no aaa new-model
no network-clock-participate slot 1 
no network-clock-participate wic 0 
ip cef
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
no ip dhcp use vrf connected
!
ip dhcp pool pollux
   network 192.168.200.0 255.255.255.0
   default-router 192.168.200.1 
   dns-server 62.6.40.178 62.6.40.162 
!
ip dhcp pool castor
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1 
   dns-server 62.6.40.178 62.6.40.162 
!
!
ip flow-cache timeout active 1
ip name-server 212.159.13.49
ip name-server 212.159.13.50
ip name-server 141.1.1.1
!
!
!
archive
 log config
  hidekeys
!
!
! 
!
!
!
interface ATM0/0
 description btbusiness
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 no atm ilmi-keepalive
 dsl operating-mode itu-dmt 
 pvc 0/38 
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
!
interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 ip flow ingress
 ip flow egress
 ip nat inside
 ip virtual-reassembly
 ip route-cache flow
 ip policy route-map castor
 duplex auto
 speed auto
!
interface ATM0/1
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 no atm ilmi-keepalive
 dsl operating-mode itu-dmt 
 pvc 0/38 
  encapsulation aal5mux ppp dialer
  dialer pool-member 2
 !
!
interface FastEthernet0/1
 ip address 192.168.200.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 ip policy route-map pollux
 duplex auto
 speed auto
!
interface Dialer0
 ip address negotiated
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 no cdp enable
 ppp authentication chap pap callin
 ppp chap hostname xxxxxxx
 ppp chap password xxxxxxx
!
interface Dialer1
 description btbusiness
 ip address negotiated
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 2
 no cdp enable
 ppp authentication chap pap callin
 ppp chap hostname xxxxxxx
 ppp chap password xxxxxxx
!
router rip
 version 2
 network 192.168.1.0
 network 192.168.200.0
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 192.168.88.0 255.255.255.0 192.168.200.2
ip route 212.159.13.49 255.255.255.255 Dialer1
ip route 212.159.13.50 255.255.255.255 Dialer1
!
no ip http server
no ip http secure-server
ip nat inside source list 12 interface Dialer0 overload
ip nat inside source list 22 interface Dialer1 overload
ip nat inside source route-map castor interface Dialer1 overload
ip nat inside source route-map pollux interface Dialer0 overload
!
access-list 12 permit 192.168.1.0 0.0.0.255
access-list 22 permit 192.168.200.0 0.0.0.255
access-list 112 deny   ip 192.168.1.0 0.0.0.255 10.0.0.0 0.255.255.255
access-list 112 deny   ip 192.168.1.0 0.0.0.255 172.16.0.0 0.15.255.255
access-list 112 deny   ip 192.168.1.0 0.0.0.255 192.168.0.0 0.0.255.255
access-list 112 permit ip 192.168.1.0 0.0.0.255 any
access-list 122 deny   ip 192.168.200.0 0.0.0.255 10.0.0.0 0.255.255.255
access-list 122 deny   ip 192.168.200.0 0.0.0.255 172.16.0.0 0.15.255.255
access-list 122 deny   ip 192.168.200.0 0.0.0.255 192.168.0.0 0.0.255.255
access-list 122 permit ip 192.168.200.0 0.0.0.255 any
route-map pollux permit 22
 match ip address 122
 set interface Dialer1
!
route-map castor permit 12
 match ip address 112
 set interface Dialer0
!
!
!
control-plane
!
!
!
alias exec arp tclsh flash:arp.tcl
alias exec shutnoshut tclsh flash:shutnoshut.tcl
!
line con 0
line aux 0
line vty 0 4
 access-class 12 in
 password xxxxx
 login
 transport input telnet
!
ntp clock-period 17207966
ntp server 85.119.80.233
!
end

 

The network worked beautifully. Another elegant solution from Rustyice Solutions.

A look at some useful PHP functions. isset() vs empty() vs is_null()

Were currently developing a new system in collaboration with our partners at 802 Works – Redefining Wireless. As a part of that, were designing a new system for administering Wireless systems and maximising the marketing leverage that can be gained from them. That job involves having to write quite a lot of PHP pages and scripts. We thought we’d share a short tip on PHP variable declaration.

We’re going to look at the different ways that variables can be empty in this post. PHP has many different operators which can be used to test a variable. Three useful operators used for this are isset(), empty() and is_null(). Each of these operators return a boolean value (either true or false).

Lets take a look at these operators in a little more detail:

isset()

From the bible of PHP, the PHP manual, isset’s job is to “determine if a variable is set and is not NULL”. In other words, it returns true only when the variable is not null.

empty()

Again from the PHP manual, empty’s job is to “determine whether a variable is empty”. In other words, it will return true if the variable is an empty string, false, array(), NULL, “0?, 0, and an unset variable.

is_null()

Finally, from the PHP manual, is_null’s jobis to “find whether a variable is NULL”. In other words, it returns true only when the variable is null.

You may now be thinking that is_null() is opposite of isset() and , broadly speaking you’d be correct however there is one difference and that is that isset() can be applied to unknown variables, but is_null() only to declared variables.

The table below is an easy reference for what these functions will return for different values.

 

Value of variable ($var) isset($var) empty($var) is_null($var)
“” (an empty string) bool(true) bool(true)  bool(false)
” ” (space) bool(true)  bool(false)  bool(false)
FALSE bool(true) bool(true)  bool(false)
TRUE bool(true)  bool(false)  bool(false)
array() (an empty array) bool(true) bool(true)  bool(false)
NULL  bool(false) bool(true) bool(true)
“0” (0 as a string) bool(true) bool(true)  bool(false)
0 (0 as an integer) bool(true) bool(true)  bool(false)
0.0 (0 as a float) bool(true) bool(true)  bool(false)
var $var; (a variable declared, but without a value)  bool(false) bool(true) bool(true)
NULL byte (“\ 0”) bool(true)  bool(false)  bool(false)

 

I have tested the above values in PHP 7.1.9 which was released on September 1, 2017.

Hosted Telephony From Rustyice Solutions

rs_logo-with-wordsRustyice Solutions Ltd. is helping to transform the way businesses communicate. We provide each customer with a single communications platform that addresses the needs of every employee, regardless of their location or the device they use.

Our cloud-based platform delivers a range of feature-rich voice, video and unifed communications solutions to your business. We help you to improve the way you communicate with your customers, increasing collaboration and ensuring maximum productivity from every employee.

JARGON BUSTER

WHAT IS HOSTED TELEPHONY?

Hosted Telephony, also known as Cloud Telephony, is where organisations access business telephony as a service. In essence, the capabilities of a traditional PBX are delivered as a service from the cloud, providing comprehensive telephony functionality directly to each extension, regardless of location.

This exible solution enables organisations to scale effortlessly and add functionality on a simple pay-as-you-use basis; including Advanced Hosted Telephony, Collaboration, Mobile Integration and Contact Centre capabilities.

Hosted Telephony is transforming the way companies communicate. Regardless of your company size or the physical location of your employees, you are able to deliver feature-rich business communications to every employee, from the cloud, wherever they may be in the world.

hosted-telepyThrough Hosted Telephony, businesses are easily able to react to change while maintaining best-in-class communications capability, enjoying:

REDUCED COSTS

With Rustyice Hosted Telephony there is no up-front capital investment required. Simply subscribe to one of our “All Inclusive” minutes bundles or take our “Pay-As-You-Use” service where you benefit from free calls between offices or employees working at home or significantly cheaper local, national and international call charges.

ADVANCED FEATURES

Take advantage of enterprise level telephony features such as Auto Attendant, Receptionist Console, Call Centre and Call Recording. Improve the efficiency of your workforce through Presence, Click-to-Dial and Contact Database Integration. Take total control of your services using our sophisticated online management portal.

INCREASED AGILITY

Flex your usage up and down in response to demand or any season fluctuations. Scale rapidly without committing to long contracts. Deploy satellite workers and seamlessly transition between different locations and offices. Take calls on the move, anywhere around the world.

FUTURE PROOF TECHNOLOGY

At Rustyice Solutions we work with key technology partners to ensure that the platform adheres to the latest versions and industry standards. A constantly evolving roadmap allows our customers to benefit automatically from the latest features and developments.

Our customers are freed from the operational and financial burden of maintaining their own equipment and software.

ASSURED RELIABILITY

Use your own, or take a business grade Inclarity broadband or fibre connection for an assured telephony experience which does not touch the public Internet. Set up cloud-based call divert rules in advance – or in real time – to capture all of your incoming calls in the event that your office experiences any local network problems. The Inclarity platform offers 99.999% availability, and in fact we achieved 100% availability across the 12 months of 2015.

HOSTED VIDEO CAPABILITY

Cloud-hosted Pay-As-You-Use video conferencing capabilities mean that there is no need for expensive dedicated meeting room equipment, complex video bridges or changes to your network. Simply connect to a meeting using your desktop, tablet or smartphone and communicate with colleagues and clients wherever they are in the world with excellent sound and picture quality.

CALL CENTRE

Call Centre is an advanced telephony feature that allows a business to better manage its incoming calls, and to ensure that these calls are answered by the correct personnel.

  • Allow agents to control how they advertise their availability for receiving calls
  • Give each agent a specialised dashboard to better manage their calls
  • Queue inbound calls, and play announcements / estimated waiting times to the callers
  • Define busy, out of hours, holiday and emergency failover responses
  • Review the availability and productivity of agents using Rustyice Reporting
  • Define the skill levels of your agents for skills based routing (Premium only)CALL RECORDINGWith Inclarity Hosted Telephony there is no need for expensive on-premise call recording, this capability is embedded within our cloud and can be switched on for particular lines or particular users.
  • User-defined recording for inbound or outbound, external and internal calls
  • Recordings are retained for 6 months as standard (with the option to extend)
  • Simple storage, search, download and playback of calls
  • Fully FSA compliant

CALL REPORTING

Rustyice Call Reporting enables you to obtain a full picture of your inbound and outbound call history so you can manage your business communications.

• Powerful GUI enables you to de ne and run reports

• Comprehensive range of standard reports

• Ability to tailor reports for your specific needs

• Leverage account codes to enable customer billing

• Schedule reports to be sent automatically to you by email

• Select from a wide range of chart and graph options to show your report data in a graphical format

AUTO-ATTENDANT

Auto-Attendant provides the ability to automate the management of inbound calls using voice prompts to identify which services are required and directing the call appropriately.

  • Direct calls to specific extensions
  • Look up individuals in the corporate directory
  • Route calls based on department or service required

Rustyice Hosted Unified Communications (UC) delivers both improvements in the productivity of your staff and an increase in the level of collaboration across your entire organisation.

The Rustyice UC Client is a desktop application that helps you integrate your telephone activity with the rest of your business processes. UC users can access their contacts more easily, and can identify the context of incoming calls more effectively, leading to a boost in productivity and efficiency. When integrated with CRM, accounting or ticketing systems, UC users can instantly spawn or pop the relevant contact records to perform essential tasks more quickly.

UC users can also use the integral Telephone Presence dashboard to see the real-time telephone status of their colleagues, and can instantly identify when these users are not available to take calls or call transfers. User collaboration on projects is improved by knowing when everyone is available to speak.

CALL PREVIEW

Receive an alert on your desktop to notify you that you are making or receiving a call. If the called/calling number is on your Address Book, then you will also see your contact’s name.

OUTLOOK INTEGRATION

Automatically access your MS Outlook Contact Cards for Call Preview, and enable click-to-dial within the MS Outlook desktop application.

OTHER APPLICATION INTEGRATION

Open up lists of contacts from other 3rd party applications for Call Preview, Click-to-Dial and Screen Pop. Supported applications include common CRM packages such as ACT, Salesforce, Sage and MS Dynamics.

TELEPHONE PRESENCE DASHBOARD

Report your current telephone status to your fellow UC users, and access a dashboard showing the current telephone status of these users.

SKYPE FOR BUSINESS INTEGRATION

Push your telephone status so that it is visible to your MS Skype for Business environment. Dial fellow Skype users on their listed telephone numbers from the Inclarity platform.

BROWSER & CLIPBOARD CLICK-TO-DIAL

Enable your preferred desktop web browser so that any telephone numbers you see can be dialled with
a single click. Copy any number from any screen or application to your clipboard, so that it can be dialled with a single click.

IMPROVED CUSTOMER SERVICE

Automatically access customer details and presenting these along with the telephone call to enable a more professional service.

MORE EFFECTIVE COLLABORATION

Provide a real time view to each user showing who is available and so enable them to reach the right expert rst time.

IMPROVED USER EXPERIENCE

Making business telephony much easier to use and provide each user with the ability to work the way they want to work.

At Rustyice, we are proud of our track record of unrivalled customer support and service.

Based on industry leading Broadsoft cloud architecture, the Rustyice hosted telephony platform is recognised by our clients as one of the most reliable cloud services available.

99.999% service uptime

The platform offers 99.999% availability, and in fact it achieved 100% availability across the 12 months of 2015. Thanks to the resilient structure and key relationships with Broadsoft and other technology partners, our clients enjoy service continuity that is second to none.

Support calls answered within 5 seconds.

We like to practice what we preach, and as a telephony company, that means being at the end of the line when our customers call. Our Ayrshire based customer support team are available 24/7/365 to help you with any issues you have.

Most issues fixed in under 2 hours

We’ve been at the forefront of unified comms and telephony for over 12 years and our engineers and support staff have intimate knowledge and experience across our platform and the partner vendors we work with. This means issues are identified and rectified quickly and efficiently.

But it’s not just about the SLA

We constantly monitor both the availability and the quality of service of our hosted platform and ensure that not only do we resolve all issues against clearly defined SLAs, but we strongly believe that there’s more to customer support than complying with Service Level Agreements. We really care about offering the right service to our customers to suit their specific needs.

That means from the very outset, we take the time to understand each and every client’s unique business and communication needs. We then work with them and our network of technology partners to produce high-quality, hosted solutions that deliver genuine business value for the short-term and support business growth in the longer-term.

 41

Advanced management tools

System Management Tool (SMT)

A web based, real-time management interface which enables your IT administrator to easily and rapidly manage account settings and resources on-line. Dependent upon the provided system access level, you can use SMT to add new accounts and resources, edit existing account settings, allocate resources, produce reports and perform other administrative tasks. Administration can be specific to an individual user or terminal (e.g. IP phone), and general for multiple users, sites and companies.

Phone Manager

A simple, web-based interface which allows each end user to manage his or her own telephone number and associated service features. This interface is available and works the same way, regardless of what terminal (telephone) is deployed for the user to make and receive telephone calls.

 

HOW WE CAN HELP

ADVICE

Years of experience in deploying hosted telephony for hundreds of clients, across many industry sectors, enables us to add value to the relationship by advising on best practice. We provide guidance as to what works best for businesses like yours and how you can maximise the returns on your investment in cloud-based communications.

DEPLOYMENT

We focus on providing end-to-end solutions; from your connection to the public telephone network right the way through to the telephones on your employees’ desks. Our experience and expertise in VoIP is unrivalled, which enables us to seamlessly transition you to Rustyice Hosted Telephony and deliver the capabilities that you need to each and every user.

FLEXIBILITY

Where we differ from some of the larger players in the Unified Communications space is our ability and willingness to work to our customers’ needs. Our agility enables us to adapt our contract terms, our technical implementations and our SLAs to ensure they support customers’ specific needs, rather than imposing standard terms and standard functionality on them. While we can always provide advice on best practice, we’re always open to different ways of doing things if it’s of benefit to our customers.

If you’d like to know a little more, stick some detail into the form below and we will be in touch soon.

The Warning Signs Your Network Needs Replaced

atlanticstormIf you think lightning can’t strike twice, think again. It can strike twice, thrice or even quarce. (Is that really a protologism?) A well known ferry operator on the West Of Scotland has the blown out network equipment to prove it. The coastal ferry terminals of Scotland are long standing facilities. Surprising to some, in the winter in Scotland, the seemingly constant procession of Atlantic storms frequently bring intense atmospheric instability with them as the UK’s TORnado and storm Research Organisation (TORRO for short) can testify. Lightning frequently is a major problem for many businesses in this area and it can have a devastating effect on their sensitive IT infrastructure. As Doug Rask, an IT manager in the area put it, “We would take an occasional lightning strike and the equipment would be fine initially, but after some days or weeks, they’d start falling over, and we’d have to analyse the problem and quickly get things replaced.” Lightning strikes are admittedly a bit of an extreme example, well concede, but they do qualify the problem of the constant environmental stresses and strains that your static sensitive network hardware has to face almost constantly.

When systems begin to show signs of this wear and tear, it can manifest itself in the shape of chronic network niggles such as poor throughput or frequent hangs, crashes and outages. The hardware may simply be coming to the end of its natural life, or perhaps the user enterprise has simply grown beyond the maximum capabilities of the network, says Pete Macsorley, IT manager at Corpach Pumps. Other factors that can cause an agency to consider a network refresh could be the deployment of new applications such as anti virus systems or phased migration and collaborative services. Usually the real world reason for a network overhaul is not just a single warning sign but a combination of multiple elements of the above.

CONSISTENT EQUIPMENT FAILURE

When lightning strikes a building, the earthing systems should and almost always will protect the systems but every now and again a strike of ferocious magnitude can overwhelm these safety systems to the point that damage is caused to the network  and IT equipment. “When we get strikes on our sites, it typically doesn’t kill of our systems there and then. It does however initiate a collapsing system which culminates in the eventual hard failure of equipment. This can take 3-6 months,” said Mark Forrest, IT engineer for a well known salmon farming company.

At some time in the next 6 months, the kit would begin to play up. Users would notice a badly performing network, intermittent hangs and patchy access to servers, forcing Forrest to carry out systematic fault finding and replace the failing kit. “Atmospherics and particularly lightning places a cost burden of 3 to 4 switches per hit” says Marks boss, Joe McGarry.

AGEING HARDWARE

headerAgeing or end-of-life networking gear can compel organisations to replace their systems, especially when the initial warranty expires and/or support organisations place a premium on their support due to the increased likelihood of call out and expensive engineering time. “Sometimes this cost uplift is so great that there is no option left but to replace new for old and enjoy the more relaxed maintenance landscape that ensues,” says Dan McDougall, CTO at a major food manufacturing company.

“Networks are there for one reason, to serve the business. Unless they’re failing too frequently, the main reason we would decide to upgrade the network is the cost of their support,” McDougall says. “Sometimes the kit on your business network is just so old that the cost of the warranty dwarfs the cost of new for old.”

For example, the salmon farming company mentioned previously recently needed to move their regional offices in Oban. It made perfect sense to look at equipping the new premises with a new network and servers because most of the kit at the old office was 5-9 years old and EOL (End Of Life), Forrest says “I was sure I didn’t want to be moving any of my old equipment that had been through the lightning hits more than once. I wanted new for old.”

They had also decided to move some services to the cloud such as their voice network services and had enhanced the resolution with which they remotely monitored the underwater salmon pens. They purchased 2 Cisco UCS servers, three new routers, eight switches and upgraded their WIFI network using Cisco Meraki, Furthermore in addition to moving to hosted voice, they improved the storage of their IP video inputs from the farm cages as well as a new access and building control system which also used the network. This network upgrade brought with it gigabit networking to the desktop and has markedly increased the performance and efficiency of the business unit.

For example, in the past, bandwidth contention had sometimes resulted in the live video from the pens squeezing out the traffic for the very control systems which were used to enable the application of feed to the pens. The upgraded network, using 802.1q VLAN trunking was able to segment the traffic and ensure that the requirements of each business process were safeguarded. Bandwidth contention had become a thing of the past. Finally and perhaps ironically, they also installed a new earthing system and new earthing cable, which should protect the new locations sensitive electronic equipment more effectively from future lightning strikes.

CREATING BANDWIDTH

Sometimes, the introduction of new applications on the network necessitates a network upgrade. For example, VoIP (hosted or owned) or realtime video services can place very specific demands on a network and if it isn’t up to the job, a refresh can prove inevitable,

An increased rollout of virtualisation and thin client technology can also drive cost savings in terms of network user hardware which may be partially offset by the costs of the new network to support it.

CONTINUOUS PHASED APPROACH

tick-tock-google-searchSome agencies adopt what is best described as a continuous phased approach to keeping the network at the cutting edge. This can prove to be a useful mitigation to the sometimes problematic expense of replacing the whole network every few years as well as enabling financial planners to smooth the requirement for capital across many financial years. It’s a cost-effective way of keeping the network stable and up to date.

DB Refrigeration in Ayr, for example, has gradually upgraded most of its 15 wiring-closet switches since 2012 and will replace a few more this year, says IT manager, Connor Piacentini.

This autumn however, it was the core routers turn to be replaced. The IT department upgraded its Gigabit Ethernet Cisco Catalyst 6509 core switch to a 6509-E which could support 10 Gigabit Ethernet. “It was 8 years old, so we knew we had to upgrade it finally,” Piacentini says.

SHARED SERVICES

Consolidation by agencies of the use of their expensive network resources seems to be a popular way to save costs these days. For example in the Public Sector, many regional councils share some of the higher end networked resources making the burden on each organisation smaller. This can however mean that the new network  must be far more capable than any of the incumbents.

Police Scotland, following its recent merger has to build regional backup emergency operations facilities, so if disaster strikes and one goes down, another can take over. The investment requires new network equipment to build the WAN. It is speculated at this time that they are also negotiating with infrastructure providers to build a proprietary fibre ring.

Upgrade Advice

1. Plan for future needs. When deciding how much bandwidth you need and what equipment to buy, don’t assess for your current needs. Spec it out for five years from now. A good rule of thumb is to plan for a 50 percent increase in bandwidth usage and a 30 percent increase in the number of employees.

2. Pair a network upgrade with a larger technology project. It’s often easier to prove return on investment and get a network upgrade funded if it’s tied to a bigger project. When IT administrators propose a private-cloud deployment, for example, they can argue that a network upgrade is critical for good cloud performance.

3. Purchase maintenance contracts only on the most critical equipment, such as main routers and switches. Purchasing contracts on all equipment can be cost-prohibitive. It can be cheaper to purchase one backup wiring closet switch and use that if a switch fails instead of purchasing contracts for each switch.